firebase_database_platform_interface 0.2.5+37 copy "firebase_database_platform_interface: ^0.2.5+37" to clipboard
firebase_database_platform_interface: ^0.2.5+37 copied to clipboard

A common platform interface for the firebase_database plugin.

1
likes
150/ 160
pub points
88%
popularity

We analyzed this package 2 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

113 out of 129 API elements (87.6 %) have documentation comments.

Some symbols that are missing documentation: firebase_database_platform_interface, firebase_database_platform_interface.DataSnapshotPlatform, firebase_database_platform_interface.DataSnapshotPlatform.DataSnapshotPlatform, firebase_database_platform_interface.DataSnapshotPlatform.child, firebase_database_platform_interface.DataSnapshotPlatform.children.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:firebase_database_platform_interface/firebase_database_platform_interface.dart that imports:
  • package:firebase_database_platform_interface/src/platform_interface/platform_interface_database.dart that imports:
  • package:firebase_database_platform_interface/src/method_channel/method_channel_database.dart that imports:
  • package:firebase_database_platform_interface/src/method_channel/utils/exception.dart that imports:
  • package:_flutterfire_internals/_flutterfire_internals.dart that imports:
  • package:_flutterfire_internals/src/exception.dart that imports:
  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firebase_database_platform_interface/firebase_database_platform_interface.dart that imports:
  • package:firebase_database_platform_interface/src/platform_interface/platform_interface_database.dart that imports:
  • package:firebase_database_platform_interface/src/method_channel/method_channel_database.dart that imports:
  • package:firebase_database_platform_interface/src/method_channel/utils/exception.dart that imports:
  • package:_flutterfire_internals/_flutterfire_internals.dart that imports:
  • package:_flutterfire_internals/src/exception.dart that imports:
  • package:firebase_core/firebase_core.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
_flutterfire_internals ^1.3.37 1.3.37 1.3.37
collection ^1.14.3 1.18.0 1.19.0
firebase_core ^3.1.0 3.1.0 3.1.0
flutter flutter 0.0.0 0.0.0
meta ^1.8.0 1.12.0 1.15.0
plugin_platform_interface ^2.1.3 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
fake_async - 1.3.1 1.3.1
firebase_core_platform_interface - 5.1.0 5.1.0
firebase_core_web - 2.17.2 2.17.2
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.