firebase_database_mocks 0.2.0+1
firebase_database_mocks: ^0.2.0+1 copied to clipboard

Fakes to write unit tests for FirebaseDatabase (real-time database).

6
likes
110/ 130
pub points
45%
popularity

We analyzed this package on Oct 21, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 8 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:firebase_database_mocks/firebase_database_mocks.dart that imports:
  • package:firebase_database_mocks/src/mock_firebase_database.dart that imports:
  • package:firebase_database_mocks/src/mock_database_reference.dart that imports:
  • package:firebase_database_mocks/src/mock_data_snapshot.dart that imports:
  • package:firebase_database/firebase_database.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core_platform_interface^4.0.14.0.14.0.1
firebase_database^7.2.17.2.28.0.1
flutterflutter0.0.00.0.0
flutter_testflutter0.0.00.0.0
mockito^5.0.155.0.165.0.16
pedantic^1.11.11.11.11.11.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-29.0.029.0.0
analyzer-2.6.02.6.0
args-2.3.02.3.0
async-2.8.12.8.2
boolean_selector-2.1.02.1.0
build-2.1.12.1.1
built_collection-5.1.15.1.1
built_value-8.1.28.1.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
clock-1.1.01.1.0
code_builder-4.1.04.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.2.02.2.0
fake_async-1.2.01.2.0
file-6.1.26.1.2
firebase_core-1.8.01.8.0
firebase_core_web-1.1.01.1.0
firebase_database_platform_interface-0.0.1+10.1.0+1
fixnum-1.0.01.0.0
flutter_web_plugins-0.0.00.0.0
glob-2.0.22.0.2
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.100.12.11
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
plugin_platform_interface-2.0.22.0.2
pub_semver-2.1.02.1.0
sky_engine-0.0.990.0.99
source_gen-1.1.11.1.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.6
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.2.1` on firebase_database does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions firebase_database to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.