firebase_database 10.5.6 copy "firebase_database: ^10.5.6" to clipboard
firebase_database: ^10.5.6 copied to clipboard

Flutter plugin for Firebase Database, a cloud-hosted NoSQL database with realtime data syncing across Android and iOS clients, and offline access.

601
likes
120/ 140
pub points
100%
popularity

We analyzed this package 11 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

128 out of 143 API elements (89.5 %) have documentation comments.

Some symbols that are missing documentation: firebase_animated_list, firebase_animated_list.FirebaseAnimatedListItemBuilder, firebase_animated_list.FirebaseAnimatedListState, firebase_animated_list.FirebaseAnimatedListState.FirebaseAnimatedListState, firebase_database.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:firebase_database/firebase_database.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:firebase_database/firebase_database.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firebase_database/firebase_database.dart that imports:
  • package:firebase_database_platform_interface/firebase_database_platform_interface.dart that imports:
  • package:firebase_database_platform_interface/src/platform_interface/platform_interface_database.dart that imports:
  • package:firebase_database_platform_interface/src/method_channel/method_channel_database.dart that imports:
  • package:firebase_database_platform_interface/src/method_channel/utils/exception.dart that imports:
  • package:_flutterfire_internals/_flutterfire_internals.dart that imports:
  • package:_flutterfire_internals/src/exception.dart that imports:
  • package:firebase_core/firebase_core.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

WARNING: The include file '../../../../../analysis_options.yaml' in '/tmp/pana_IBMVQS/lib/ui/analysis_options.yaml' can't be found when analyzing '/tmp/pana_IBMVQS/lib/ui'.

lib/ui/analysis_options.yaml:5:10

  ╷
5 │ include: ../../../../../analysis_options.yaml
  │          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ui/analysis_options.yaml

INFO: The part-of directive uses a library name.

lib/src/data_snapshot.dart:5:1

  ╷
5 │ part of firebase_database;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/data_snapshot.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
firebase_core ^2.31.1 2.31.1 2.31.1
firebase_core_platform_interface ^5.0.0 5.0.0 5.0.0
firebase_database_platform_interface ^0.2.5+34 0.2.5+34 0.2.5+34
firebase_database_web ^0.2.5+6 0.2.5+6 0.2.5+6
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.34 1.3.34
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
firebase_core_web - 2.17.0 2.17.0
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

601
likes
120
pub points
100%
popularity

Publisher

verified publisherfirebase.google.com

Flutter plugin for Firebase Database, a cloud-hosted NoSQL database with realtime data syncing across Android and iOS clients, and offline access.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

firebase_core, firebase_core_platform_interface, firebase_database_platform_interface, firebase_database_web, flutter

More

Packages that depend on firebase_database