firebase_dart_ui 0.2.0
firebase_dart_ui: ^0.2.0 copied to clipboard

An Angular Dart wrapper for Firebase UI. Demo app at https://dart-ui-demo.firebaseapp.com/

0
likes
60 / 130
pub points
16 %
popularity

We analyzed this package on Jun 23, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 65 API elements (3.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:firebase_dart_ui/firebase_dart_ui.dart that imports:
  • package:firebase_dart_ui/src/auth_ui_js.dart that imports:
  • package:firebase/src/interop/es6_interop.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/firebase_auth_ui_component.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^6.0.06.0.16.0.1
firebase^7.3.07.3.39.0.1
js^0.6.1+10.6.30.6.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.022.0.0
analyzer-0.40.61.7.1
angular_ast-1.0.11.0.1
angular_compiler-1.0.11.0.1
args-1.6.02.1.1
async-2.7.02.7.0
build-1.6.22.0.2
build_config-0.4.71.0.0
built_collection-5.1.05.1.0
built_value-8.1.08.1.0
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
code_builder-3.7.04.0.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.102.0.1
file-5.2.16.1.2
fixnum-1.0.01.0.0
glob-1.2.02.0.1
http-0.12.20.13.3
http_parser-3.1.44.0.0
intl-0.16.10.17.0
json_annotation-4.0.14.0.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.4.01.4.0
node_interop-1.2.12.0.2
node_io-1.2.02.1.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
source_gen-0.9.10+21.0.2
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.3.0` on firebase does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions firebase to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Dart 2.13.3.

0
likes
60
pub points
16%
popularity

Publisher

Unknown

An Angular Dart wrapper for Firebase UI. Demo app at https://dart-ui-demo.firebaseapp.com/

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angular, firebase, js

More

Packages that depend on firebase_dart_ui