firebase_crashlytics_platform_interface 1.1.6
firebase_crashlytics_platform_interface: ^1.1.6 copied to clipboard

Flutter Android iOS macOS web
unlisted

A common platform interface for the firebase_crashlytics plugin.

0
likes
90 / 110
pub points
99 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 35 out of 36 API elements (97.2 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_crashlytics_platform_interface/firebase_crashlytics_platform_interface.dart that imports:
  • package:firebase_crashlytics_platform_interface/src/method_channel/method_channel_crashlytics.dart that imports:
  • package:firebase_crashlytics_platform_interface/src/platform_interface/platform_interface_crashlytics.dart that imports:
  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
Because firebase_core 0.7.0 depends on firebase_core_platform_interface ^3.0.1 and no versions of firebase_core match >0.7.0 <0.8.0, firebase_core ^0.7.0 requires firebase_core_platform_interface ^3.0.1.
So, because firebase_crashlytics_platform_interface depends on both firebase_core ^0.7.0 and firebase_core_platform_interface ^2.0.0, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.