firebase_core_web 0.2.1+1
firebase_core_web: ^0.2.1+1

Flutter web

The web implementation of firebase_core

8
likes
60 / 110
pub points
100 %
popularity

We analyzed this package on Dec 2, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 26 out of 72 API elements (36.1 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:firebase_core_web/firebase_core_web.dart that declares support for platforms: Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/interop/core_interop.dart:21:21

   ╷
21 │ external String get SDK_VERSION;
   │                     ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/interop/core_interop.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core_platform_interface^2.1.02.1.02.1.0
js^0.6.1+10.6.3-nullsafety.30.6.3-nullsafety.3
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
matcher-0.12.90.12.10-nullsafety.3
path-1.7.01.8.0-nullsafety.3
plugin_platform_interface-1.0.31.0.3
quiver-2.1.52.1.5
stack_trace-1.9.61.10.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs