firebase_core_vm 0.0.8
firebase_core_vm: ^0.0.8 copied to clipboard

Dart implementation of Firebase Core SDK that provides FirebaseApps used by all Firebase services

2
likes
85 / 130
pub points
67 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 85 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:83:59

   ╷
83 │ <li>Generate the SHA1 hash of this part. You can use this <a href="http://www.sha1-online.com/">tool</a></li>
   │                                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 71 out of 103 API elements (68.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/firebase_core_vm.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/firebase_app.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
_firebase_internal_vm^0.0.2+10.0.2+10.0.2+1
hive^1.4.41.4.4+12.0.4
meta>=1.0.0 <2.0.01.7.01.7.0
rxdart^0.24.10.24.10.27.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.4.4` on hive does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions hive to update the constraint.

The constraint `^0.24.1` on rxdart does not support the stable version `0.25.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

2
likes
85
pub points
67%
popularity

Publisher

long1.eu

Dart implementation of Firebase Core SDK that provides FirebaseApps used by all Firebase services

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

_firebase_internal_vm, hive, meta, rxdart

More

Packages that depend on firebase_core_vm