firebase_core 0.7.0
firebase_core: ^0.7.0 copied to clipboard

Flutter Android iOS macOS web

Flutter plugin for Firebase Core, enabling connecting to multiple Firebase apps.

659
likes
110 / 110
pub points
100 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 16 API elements (81.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 3 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core_platform_interface^3.0.13.0.14.0.0
firebase_core_web^0.2.1+30.2.1+31.0.0
flutterflutter0.0.00.0.0
meta^1.1.81.3.0-nullsafety.31.3.0
quiver>=2.0.0 <3.0.02.1.53.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
flutter_web_plugins-0.0.00.0.0
js-0.6.20.6.3
matcher-0.12.90.12.10
path-1.7.01.8.0
sky_engine-0.0.990.0.99
stack_trace-1.9.61.10.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.1` on firebase_core_platform_interface does not support the stable version `4.0.0`, that was published 5 days ago.

When firebase_core_platform_interface is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_core_platform_interface to update the constraint.

The constraint `^0.2.1+3` on firebase_core_web does not support the stable version `1.0.0`, that was published 5 days ago.

When firebase_core_web is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_core_web to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

659
likes
110
pub points
100%
popularity

Publisher

firebase.google.com

Flutter plugin for Firebase Core, enabling connecting to multiple Firebase apps.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

firebase_core_platform_interface, firebase_core_web, flutter, meta, quiver

More

Packages that depend on firebase_core