firebase_auth_vm 0.0.3
firebase_auth_vm: ^0.0.3 copied to clipboard

Dart implementation of Firebase Auth SDK that offers secure End-To-End Authentication

0
likes
80 / 130
pub points
47 %
popularity

We analyzed this package on Jul 23, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 261 out of 387 API elements (67.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:firebase_auth_vm/firebase_auth_vm.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

lib/firebase_auth_vm.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/auth_providers.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
_discoveryapis_commons^0.2.00.2.11.0.1
_firebase_internal_vm^0.0.2+10.0.2+10.0.2+1
firebase^7.3.07.3.39.0.1
firebase_core_vm^0.0.80.0.80.0.8
googleapis^0.55.00.55.04.0.0
googleapis_auth^0.2.120.2.12+11.1.0
http^0.12.20.12.20.13.3
meta>=1.0.0 <2.0.01.7.01.7.0
rxdart^0.24.10.24.10.27.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
hive-1.4.4+12.0.4
http_parser-3.1.44.0.0
js-0.6.30.6.3
path-1.8.01.8.0
pedantic-1.11.11.11.1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.2.0` on _discoveryapis_commons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions _discoveryapis_commons to update the constraint.

The constraint `^7.3.0` on firebase does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions firebase to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

0
likes
80
pub points
47%
popularity

Publisher

long1.eu

Dart implementation of Firebase Auth SDK that offers secure End-To-End Authentication

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

_discoveryapis_commons, _firebase_internal_vm, firebase, firebase_core_vm, googleapis, googleapis_auth, http, meta, rxdart

More

Packages that depend on firebase_auth_vm