firebase_analytics_web 0.1.1
firebase_analytics_web: ^0.1.1 copied to clipboard

Flutter web

The web implementation of firebase_analytics

2
likes
60 / 110
pub points
99 %
popularity

We analyzed this package on Feb 25, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 9 API elements (88.9 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Android

Because:

  • package:firebase_analytics_web/firebase_analytics_web.dart that declares support for platforms: Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase^7.3.07.3.39.0.0
firebase_analytics_platform_interface^1.0.11.0.31.0.3
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
meta^1.1.81.3.0-nullsafety.31.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
js-0.6.20.6.3
path-1.7.01.8.0
pedantic-1.9.21.10.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.3.0` on firebase does not support the latest published version `9.0.0`

pubspec.yaml:18:13

   ╷
18 │   firebase: ^7.3.0
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.