firebase_admin 0.3.0-dev.3 icon indicating copy to clipboard operation
firebase_admin: ^0.3.0-dev.3 copied to clipboard

A port of the Firebase admin sdk to pure, idiomatic Dart code

0.3.0-dev.3 #

  • FIX: throw FirebaseAuthError on error from identitytoolkit server. (f05c9893)

0.3.0-dev.2 #

  • FIX: getting and updating multi factor enrollments. (9a5d9627)

0.3.0-dev.1 #

  • FIX: nullability lastSignInTime. (84777a48)

0.3.0-dev.0 #

  • REFACTOR: use firebaseapis for identitytoolkit api calls. (9296f1de)
  • FIX: lastSignInTime returning null. (d5a5d653)
  • FEAT: support multi factor. (4449df83)
  • FEAT: mock auth requests when testing. (2273c1f9)

0.2.0 #

  • null safety

0.1.4 #

  • upgrade openid_client dependency to 0.3.1

0.1.3 #

  • fix certFromPath (see issue #3)
  • Credentials.applicationDefault now also looks for a service-account.json file in the package main directory

0.1.2+1 #

  • support latest dependencies

0.1.2 #

  • admin sdk for firebase storage

0.1.1 #

  • look for default credentials in Firebase CLI configurations
  • get credentials by openid login

0.1.0 #

  • admin sdk for firebase realtime database
  • admin sdk for firebase authentication
67
likes
130
pub points
90%
popularity

Publisher

verified publisher iconappsup.be

A port of the Firebase admin sdk to pure, idiomatic Dart code

Repository (GitHub)

License

Icon for licenses.Apache-2.0, BSD-3-Clause (LICENSE)

Dependencies

_discoveryapis_commons, clock, collection, crypto_keys, dotenv, firebase_dart, firebaseapis, gcloud, http, jose, meta, openid_client, path, snapshot, x509

More

Packages that depend on firebase_admin