firebase3 0.2.3

  • Readme
  • Changelog
  • Installing
  • 0

DEPRECATED: Dart wrapper library for the new Firebase #

This library is now deprecated and moved to the official firebase-dart.

0.2.3 #

  • BREAKING This library is now deprecated and moved to firebase-dart.
  • Update to Firebase 3.6.2.
  • Support for custom OAuth parameters with GoogleAuthProvider.setCustomParameters(), FacebookAuthProvider.setCustomParameters(), GithubAuthProvider.setCustomParameters() and TwitterAuthProvider.setCustomParameters() methods.
  • AuthCredential now has the accessToken and secret (Twitter only) properties.
  • Added an implementation of simple, server access to Firebase realtime database via firebase_io.dart.

0.2.2 #

  • Update to Firebase 3.4.0.
  • Added isEqual() method for Query class.
  • Strong mode fixes.
  • More docs.

0.2.1 #

  • Input params validation for methods which work with JS types.
  • Fixes in the lib.
  • More documentation and tests.
  • Readme update with information on how to run tests and examples.

0.2.0 #

  • BREAKING Exposing only one top-level library: firebase.dart.
  • BREAKING ThenableReference and UploadTask are having future property to handle then() and catchError().
  • BREAKING CustomMetadata is now a Map.
  • BREAKING Storage APIs now expose Uri and DateTime instead of String where appropriate.
  • BREAKING Storage onStateChanged returns Stream<UploadTaskSnapshot>.
  • Updates and fixes in examples
  • Fixes in the lib

0.1.0 #

  • Initial version of library

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  firebase3: ^0.2.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:firebase3/firebase.dart';
import 'package:firebase3/firebase_io.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.18.0 <2.0.0