finbox_dc_plugin 1.0.16 copy "finbox_dc_plugin: ^1.0.16" to clipboard
finbox_dc_plugin: ^1.0.16 copied to clipboard

PlatformAndroid

Device Connect Flutter SDK is used to collect anonymised non-PII data from the devices of the users after taking explicit user consent

0
likes
110/ 160
pub points
90%
popularity

We analyzed this package 19 hours ago, and awarded it 110 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://gitlab.com/finbox/flutter-deviceconnect/-/tree/master was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: finbox_dc_plugin,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 15 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: finbox_dc_plugin, finbox_dc_plugin.FinBoxDcPlugin, finbox_dc_plugin.FinBoxDcPlugin.FinBoxDcPlugin, finbox_dc_plugin.FinBoxDcPlugin.createUser, finbox_dc_plugin.FinBoxDcPlugin.forgetUser.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:finbox_dc_plugin/finbox_dc_plugin.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:finbox_dc_plugin/finbox_dc_plugin.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:finbox_dc_plugin/finbox_dc_plugin.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:finbox_dc_plugin/finbox_dc_plugin.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:finbox_dc_plugin/finbox_dc_plugin.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/finbox_dc_plugin.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
either_dart ^0.1.4 0.1.4 1.0.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.4` on either_dart does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions either_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
110
pub points
90%
popularity

Publisher

verified publisherfinbox.in

Device Connect Flutter SDK is used to collect anonymised non-PII data from the devices of the users after taking explicit user consent

Repository (GitLab)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

either_dart, flutter

More

Packages that depend on finbox_dc_plugin