file_icon 0.3.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 81

File Icon for Flutter #

pub

File Icon for Flutter, port of Seti UI icons.

Usage #

import 'package:flutter/material.dart';
import 'package:file_icon/file_icon.dart';

class MyWidget extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return FileIcon(
      // File name
      'main.dart',

      // Icon size
      size: 32,
    );
  }
}

License #

MIT

[0.3.0] - 2020-02-10 #

  • Rename to file_icon
  • update seti-ui from upstream

[0.2.0] - 2019-09-11 #

  • Refactor

[0.1.0] - 2019-09-09 #

  • First release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:file_icon/file_icon.dart';
import 'package:url_launcher/url_launcher.dart';

void main() => runApp(MyApp());

const title = 'File icon for Flutter';

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: title,
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  String _input = 'main.dart';
  double _size = 100;

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(title),
        actions: <Widget>[
          InkWell(
            child: FileIcon('.html', size: 32),
            onTap: () {
              launch('https://github.com/pd4d10/file-icon');
            },
          )
        ],
      ),
      body: Padding(
        padding: const EdgeInsets.all(20),
        child: Column(
          children: <Widget>[
            TextField(
              onChanged: (v) {
                _input = v;
              },
              decoration: InputDecoration(
                border: OutlineInputBorder(),
                hintText: 'File name',
                labelText: 'Input file name here',
              ),
            ),
            Slider(
              value: _size,
              onChanged: (v) {
                setState(() {
                  _size = v;
                });
              },
              max: 300,
            ),
            Center(
              child: Column(
                mainAxisAlignment: MainAxisAlignment.center,
                children: <Widget>[FileIcon(_input, size: _size)],
              ),
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  file_icon: ^0.3.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:file_icon/file_icon.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
67
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Jun 5, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev
  • Flutter: 1.17.1

Health suggestions

Fix lib/src/data.dart. (-9.54 points)

Analysis of lib/src/data.dart reported 20 hints, including:

line 5 col 7: The declaration '_apple' isn't referenced.

line 16 col 7: The declaration '_checkbox_unchecked' isn't referenced.

line 17 col 7: The declaration '_checkbox' isn't referenced.

line 18 col 7: The declaration '_cjsx' isn't referenced.

line 24 col 7: The declaration '_coffee_erb' isn't referenced.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test