figma_theme_generator 0.1.8
figma_theme_generator: ^0.1.8

Generate themes from Figma styles.

0
likes
60 / 110
pub points
41 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 11 API elements (9.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-native on Android

Because:

  • package:figma_theme_generator/figma_theme_generator.dart that imports:
  • package:figma_theme_generator/src/generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.140.39.170.41.0
build^1.0.01.5.11.5.1
code_builder^3.2.03.5.03.5.0
dart_style^1.3.61.3.61.3.10
figma^2.0.32.1.02.1.0
figma_theme^0.1.10.1.10.1.1
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
recase^3.0.03.0.13.0.1
source_gen^0.9.70.9.80.9.8
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.013.0.0
args-1.6.01.6.0
async-2.4.22.4.2
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
copy_with_extension-1.4.01.4.0
crypto-2.1.52.1.5
csslib-0.16.20.16.2
equatable-1.2.51.2.5
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
http2-1.0.11.0.1
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.13.1.1
logging-0.11.40.11.4
matcher-0.12.90.12.9
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
quiver-2.1.52.1.5
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.39.14` on analyzer does not support the latest published version `0.41.0`

pubspec.yaml:13:13

   ╷
13 │   analyzer: ^0.39.14
   │             ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs