fhir_yaml 0.2.1
fhir_yaml: ^0.2.1 copied to clipboard

Dart package to format JSON data to YAML. Supports formatting conventions of pubspec files.

example/main.dart

/// From Package: https://github.com/alexei-sintotski/json2yaml
/// https://github.com/alexei-sintotski/json2yaml/blob/master/example/main.dart

import 'package:fhir_yaml/fhir_yaml.dart';

// ignore_for_file: avoid_print

void main() {
  const developerData = {
    'name': "Martin D'vloper",
    'job': 'Developer',
    'skill': 'Elite',
    'employed': true,
    'foods': ['Apple', 'Orange', 'Strawberry', 'Mango'],
    'languages': {
      'perl': 'Elite',
      'python': 'Elite',
      'pascal': 'Lame',
    },
    'education': '4 GCSEs\n3 A-Levels\nBSc in the Internet of Things'
  };

  print(json2yaml(developerData));
}
5
likes
110
pub points
82%
popularity

Publisher

fhirfli.dev

Dart package to format JSON data to YAML. Supports formatting conventions of pubspec files.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

More

Packages that depend on fhir_yaml