fhir 0.2.4
fhir: ^0.2.4 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

FHIR library of versions R4, STU3, DSTU2, and R5 (draft) for Dart & Flutter.

13
likes
85 / 110
pub points
75 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:146:5

    ╷
146 │ <h2><a href="http://hl7.org/fhir/stu3/resourcelist.html">Resource Index Stu3</a></h2>
    │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc timed out with the following output:

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Equality operator `==` invocation with references of unrelated types.

lib/primitive_types/date.dart:70:13

   ╷
70 │           ? o == value
   │             ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/primitive_types/date.dart

INFO: Equality operator `==` invocation with references of unrelated types.

lib/primitive_types/fhir_date_time.dart:73:13

   ╷
73 │           ? o == value
   │             ^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/primitive_types/fhir_date_time.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dartz^0.9.20.9.20.9.2
fhir_yaml^0.2.10.2.10.2.1
freezed_annotation^0.12.00.12.00.12.0
json_annotation^3.1.13.1.14.0.0
string_validator^0.1.40.1.40.1.4
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.2.0
collection-1.14.131.15.0
meta-1.2.41.3.0
path-1.7.01.8.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.1` on json_annotation does not support the stable version `4.0.0`, that was published 14 days ago.

When json_annotation is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

The constraint `^2.2.1` on yaml does not support the stable version `3.0.0`, that was published 21 days ago.

When yaml is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

13
likes
85
pub points
75%
popularity

Publisher

fhirfli.dev

FHIR library of versions R4, STU3, DSTU2, and R5 (draft) for Dart & Flutter.

Homepage
Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

dartz, fhir_yaml, freezed_annotation, json_annotation, string_validator, yaml

More

Packages that depend on fhir