ffmpeg_kit_flutter_https_gpl 6.0.3 icon indicating copy to clipboard operation
ffmpeg_kit_flutter_https_gpl: ^6.0.3 copied to clipboard

unlisted

FFmpeg Kit for Flutter. Supports Android, iOS and macOS platforms.

2
likes
110/ 140
pub points
87%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: ffmpeg_kit_flutter_https_gpl,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: ffmpeg_kit_flutter_https_gpl.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: LGPL-3.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

244 out of 352 API elements (69.3 %) have documentation comments.

Some symbols that are missing documentation: abstract_session, AbstractSession, arch_detect, ArchDetect, chapter.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ffmpeg_kit_flutter_https_gpl/abstract_session.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:ffmpeg_kit_flutter_https_gpl/abstract_session.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:ffmpeg_kit_flutter_https_gpl/abstract_session.dart that declares support for platforms: Android, iOS, macOS.
icon indicating section status
Pass static analysis
40 / 50icon to trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 50 issues. Showing the first 2:

INFO: Redundant initialization to 'null'.

lib/abstract_session.dart:270:33

    ╷
270 │   Future<List<Log>> getAllLogs([int? waitTimeout = null]) async {
    │                                 ^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/abstract_session.dart

INFO: Redundant initialization to 'null'.

lib/abstract_session.dart:316:39

    ╷
316 │   Future<String?> getAllLogsAsString([int? waitTimeout = null]) async {
    │                                       ^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/abstract_session.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffmpeg_kit_flutter_platform_interface ^0.2.1 0.2.1 0.2.1
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.5.0 0.8.0
meta - 1.10.0 1.11.0
plugin_platform_interface - 2.1.7 2.1.7
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.3.0 0.4.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.21.43, Flutter 3.16.1, Dart 3.2.1.

Check the analysis log for details.

2
likes
110
pub points
87%
popularity

Publisher

verified publisher iconarthenica.com

FFmpeg Kit for Flutter. Supports Android, iOS and macOS platforms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.LGPL-3.0 (LICENSE)

Dependencies

ffmpeg_kit_flutter_platform_interface, flutter

More

Packages that depend on ffmpeg_kit_flutter_https_gpl