ffloat 1.0.1
ffloat: ^1.0.1

Flutter Android iOS web

FFloat, although simple and easy to use, can satisfy all your imagination of the floating layer.

37
likes
95 / 110
pub points
78 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 95 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:15:5

   ╷
15 │ </a><a href="http://www.apache.org/licenses/LICENSE-2.0.txt">
   │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 47 out of 75 API elements (62.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/ffloat.dart:816:7

    ╷
816 │       overflow: Overflow.visible,
    │       ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/ffloat.dart

INFO: 'Overflow' is deprecated and shouldn't be used. Use clipBehavior instead. See the migration guide in flutter.dev/go/clip-behavior. This feature was deprecated after v1.22.0-12.0.pre..

lib/ffloat.dart:816:17

    ╷
816 │       overflow: Overflow.visible,
    │                 ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/ffloat.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

37
likes
95
pub points
78%
popularity

FFloat, although simple and easy to use, can satisfy all your imagination of the floating layer.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

icechenx@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on ffloat