ffi_utils 0.1.1
ffi_utils: ^0.1.1 copied to clipboard

FFI Utils

0
likes
60 / 110
pub points
52 %
popularity

We analyzed this package on Apr 7, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://gitlab.com/ext/dart-ffi-utils was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 20 API elements (15.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:ffi_utils/ffi_utils.dart that imports:
  • package:ffi_utils/src/ffi_utils.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/allocation.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'addressOf' is deprecated and shouldn't be used. Hold on to the pointer backing a struct instead..

lib/src/ffi_utils.dart:56:29

   ╷
56 │     return fromPointer(this.addressOf);
   │                             ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/ffi_utils.dart

lib/src/ffi_utils.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi^0.1.30.1.31.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3` on ffi does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.