ff_flutter_client_sdk 2.2.0 copy "ff_flutter_client_sdk: ^2.2.0" to clipboard
ff_flutter_client_sdk: ^2.2.0 copied to clipboard

Feature Flag Management platform from Harness. Flutter SDK can be used to integrate with the platform in your Flutter applications.

2
likes
100/ 140
pub points
34%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

17 out of 131 API elements (13.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: ff_flutter_client_sdk, ff_flutter_client_sdk.CfClient.convertValueByKind, ff_flutter_client_sdk.CfClient.getInstance, ff_flutter_client_sdk.CfClient.jsonVariation, ff_flutter_client_sdk.CfConfiguration.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ff_flutter_client_sdk/CfClient.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:ff_flutter_client_sdk/CfClient.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:ff_flutter_client_sdk/CfClient.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Android

Because:

  • package:ff_flutter_client_sdk/FfFlutterClientSDKWebPlugin.dart that imports:
  • package:ff_flutter_client_sdk/web_plugin_internal//FfJavascriptSDKInterop.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Package not compatible with platform iOS

Because:

  • package:ff_flutter_client_sdk/FfFlutterClientSDKWebPlugin.dart that imports:
  • package:ff_flutter_client_sdk/web_plugin_internal//FfJavascriptSDKInterop.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: The file name 'CfClient.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/CfClient.dart

INFO: Use the generic function type syntax in 'typedef's.

lib/CfClient.dart:73:14

   ╷
73 │ typedef void CfEventsListener(dynamic data, EventType eventType);
   │              ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/CfClient.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
js ^0.6.3 0.6.7 0.7.1
logging ^1.1.1 1.2.0 1.2.0
uuid ^4.3.3 4.4.0 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.3` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

2
likes
100
pub points
34%
popularity

Publisher

verified publisherharness.io

Feature Flag Management platform from Harness. Flutter SDK can be used to integrate with the platform in your Flutter applications.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_web_plugins, js, logging, uuid

More

Packages that depend on ff_flutter_client_sdk