fetch_more 2.0.1
fetch_more: ^2.0.1 copied to clipboard

A Flutter package that helps to collect and show data inside a ListView with a limit and fetch more when user needs more data.

8
likes
90 / 130
pub points
52 %
popularity

We analyzed this package on May 8, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 23 out of 80 API elements (28.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/fetch_more.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^4.0.04.0.07.0.0
equatable^1.0.31.2.62.0.0
flutterflutter0.0.00.0.0
flutter_bloc^4.0.04.0.17.0.0
meta^1.1.81.3.01.3.0
rxdart^0.24.10.24.10.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
nested-1.0.01.0.0
provider-4.3.35.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^4.0.0` on bloc does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions bloc to update the constraint.

The constraint `^1.0.3` on equatable does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

8
likes
90
pub points
52%
popularity

A Flutter package that helps to collect and show data inside a ListView with a limit and fetch more when user needs more data.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ciplionat35@gmail.com

License

MIT (LICENSE)

Dependencies

bloc, equatable, flutter, flutter_bloc, meta, rxdart

More

Packages that depend on fetch_more