fereader 0.2.0
fereader: ^0.2.0 copied to clipboard

A Flutter epub reader for iOS and Android which wraps the folioreader framework.

4
likes
90/ 130
pub points
45%
popularity

We analyzed this package on Oct 13, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 33 API elements (27.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:fereader/fereader.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
path^1.7.01.8.01.8.0
path_provider^1.6.141.6.282.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path_provider_linux-0.0.1+22.1.0
path_provider_macos-0.0.4+82.0.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.34.2.3
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.6.14` on path_provider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

4
likes
90
pub points
45%
popularity

Publisher

mca.io

A Flutter epub reader for iOS and Android which wraps the folioreader framework.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, path, path_provider

More

Packages that depend on fereader