feed_finder 1.0.6

  • Readme
  • Changelog
  • Example
  • Installing
  • 74

Extracts RSS/Atom feed links from a website.

Will both look for feeds in the tags, but also throughout the website itself.

Modelled after https://alex.miller.im/posts/python-3-feedfinder-rss-detection-from-url/.

1.0.6 #

  • Removed dependency on webfeed, which relies on a very old XML lib.

1.0.5 #

  • Fix for naked URLs in

1.0.4 #

  • Fix for relative URLs found in

1.0.3 #

  • Fixed an issue with returning List

1.0.2 #

  • Missing return type

1.0.1 #

  • Doc fixes for better score on pub.dev

1.0.0 #

  • Initial version, created by Stagehand

example/feed_finder_example.dart

import 'package:feed_finder/feed_finder.dart';

main() async {
  var links = [
    'http://www.braziltravelblog.com/',
    'https://www.protocol.com/',
    'https://www.dcrainmaker.com/',
    'https://rikatillsammans.se/',
    'https://strengthrunning.com/',
    'http://www.europe-v-facebook.org/',
    'https://www.hotelnewsresource.com/',
    'https://www.traveldailynews.com'
  ];
  for (var link in links) {
    print(await FeedFinder.scrape(link));
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  feed_finder: ^1.0.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:feed_finder/feed_finder.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
html ^0.14.0+3 0.14.0+3
http ^0.12.0+4 0.12.1
Transitive dependencies
charcode 1.1.3
collection 1.14.13 1.15.0-nullsafety
csslib 0.16.1
http_parser 3.1.4
meta 1.2.2 1.3.0-nullsafety
path 1.7.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nullsafety
Dev dependencies
pedantic ^1.8.0 1.9.2
test ^1.6.0