feathers_socket_client 0.0.3
feathers_socket_client: ^0.0.3 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Simple client for feathersjs using sockets. This library is developed to facilitate connection. (Developing)

5
likes
80 / 110
pub points
4 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://featherflutterapi.qvaweb.com/ was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 27 API elements (3.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/featherjs_client.dart:1:1

  ╷
1 │ ┌ /**
2 │ │  * @ Author: Carlos Henry Céspedes <chenryhabana205@gmail.com>
3 │ │  * @ Create Time: 2020-02-18 18:13:47
4 │ │  * @ Modified by: Carlos Henry Céspedes <chenryhabana205@gmail.com>
5 │ │  * @ Modified time: 2020-02-18 19:39:08
6 │ │  * @ Description:
7 │ └  */
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/featherjs_client.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/featherjs_client.dart:167:27

    ╷
167 │     List<T> currentList = List();
    │                           ^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/featherjs_client.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
event_bus^1.1.11.1.12.0.0
flutterflutter0.0.00.0.0
socket_io_client^0.9.7+20.9.120.9.12
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
logging-0.11.41.0.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
socket_io_common-0.9.20.9.2
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.1` on event_bus does not support the stable version `2.0.0`, that was published 0 days ago.

When event_bus is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions event_bus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).

5
likes
80
pub points
4%
popularity

Publisher

qva2world.com

Simple client for feathersjs using sockets. This library is developed to facilitate connection. (Developing)

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

GPL 3.0 (LICENSE)

Dependencies

event_bus, flutter, socket_io_client

More

Packages that depend on feathers_socket_client