fd_lints 2.2.0 copy "fd_lints: ^2.2.0" to clipboard
fd_lints: ^2.2.0 copied to clipboard

An opiniated set of lint rules for Dart and Flutter projects. Made by yours truly Floating Dartists.

1
likes
140/ 140
pub points
38%
popularity

We analyzed this package 20 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 2 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: fd_lints.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:fd_lints/fd_lints.dart that imports:
  • package:fd_lints/src/lints/avoid_non_null_assertion.dart that imports:
  • package:custom_lint_builder/custom_lint_builder.dart that imports:
  • package:custom_lint_core/custom_lint_core.dart that imports:
  • package:custom_lint_core/src/type_checker.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/error/error_code_values.g.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/fasta/doc_comment_builder.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/resolver.dart that imports:
  • package:analyzer/src/generated/static_type_analyzer.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inference_helper.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inferrer.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/resolver/flow_analysis_visitor.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/link.dart that imports:
  • package:analyzer/src/summary2/types_builder.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:analyzer/src/file_system/file_system.dart that imports:
  • package:analyzer/src/util/uri.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/context/source.dart that imports:
  • package:analyzer/src/workspace/pub.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/blaze.dart that imports:
  • package:analyzer/src/workspace/blaze_watcher.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=5.12.0 <7.0.0 6.4.1 6.4.1
analyzer_plugin ^0.11.2 0.11.3 0.11.3
custom_lint_builder >=0.5.2 <0.6.0 0.5.14 0.6.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
checked_yaml - 2.0.3 2.0.3
ci - 0.1.0 0.1.0
cli_util - 0.4.1 0.4.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
custom_lint - 0.5.11 0.6.2
custom_lint_core - 0.5.14 0.6.2
dart_style - 2.3.4 2.3.4
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
freezed_annotation - 2.4.1 2.4.1
glob - 2.1.2 2.1.2
hotreloader - 4.2.0 4.2.0
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.12.0 1.12.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
rxdart - 0.27.7 0.27.7
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
uuid - 4.3.3 4.3.3
vm_service - 14.0.0 14.0.0
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.5.2 <0.6.0` on custom_lint_builder does not support the stable version `0.6.0`, that was published 23 days ago.

When custom_lint_builder is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions custom_lint_builder to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

1
likes
140
pub points
38%
popularity

Publisher

verified publisherfloating-dartists.dev

An opiniated set of lint rules for Dart and Flutter projects. Made by yours truly Floating Dartists.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, analyzer_plugin, custom_lint_builder

More

Packages that depend on fd_lints