fcm_push_node_interop 1.0.3 copy "fcm_push_node_interop: ^1.0.3" to clipboard
fcm_push_node_interop: ^1.0.3 copied to clipboard

A Dart interface to Firebase Cloud Messaging (FCM) for NodeJS

1
likes
30/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 30 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.3.0-dev <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.0. Cannot run `dart pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.3.0-dev <3.0.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.0.

pubspec.yaml:8:8

  ╷
8 │   sdk: '>=2.3.0-dev <3.0.0'
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

1
likes
30
pub points
0%
popularity

Publisher

verified publisherdvaplus.eu

A Dart interface to Firebase Cloud Messaging (FCM) for NodeJS

Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

node_http

More

Packages that depend on fcm_push_node_interop