fb_accountkit_flutter 1.0.0
fb_accountkit_flutter: ^1.0.0 copied to clipboard

A Facebook Account Kit Plugin for Flutter. Helping sms authentication for mobile phone, easy to integration and use.

1
likes
80 / 130
pub points
0 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 22 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:fb_accountkit_flutter/fb_accountkit_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/fb_accountkit_flutter.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.4.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

1
likes
80
pub points
0%
popularity

Publisher

Unknown

A Facebook Account Kit Plugin for Flutter. Helping sms authentication for mobile phone, easy to integration and use.

Homepage

Documentation

API reference

License

LICENSE

Dependencies

flutter

More

Packages that depend on fb_accountkit_flutter