fastnet 1.0.2
fastnet: ^1.0.2 copied to clipboard

A Dart package that allows you to test your network download and upload speed using fast.com.

2
likes
80 / 130
pub points
67 %
popularity

We analyzed this package on Jun 24, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 14 API elements (7.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:fastnet/fastnet.dart that imports:
  • package:fastnet/src/fastnet.dart that imports:
  • package:puppeteer/puppeteer.dart that imports:
  • package:puppeteer/src/target.dart that imports:
  • package:puppeteer/src/page/worker.dart that imports:
  • package:puppeteer/src/page/execution_context.dart that imports:
  • package:puppeteer/src/page/page.dart that imports:
  • package:puppeteer/src/page/tracing.dart that imports:
  • package:puppeteer/protocol/io.dart that imports:
  • package:puppeteer/protocol/runtime.dart that imports:
  • package:puppeteer/src/connection.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
equatable^1.2.51.2.62.0.3
flutterflutter0.0.00.0.0
puppeteer^1.18.01.22.02.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.1.1
async-2.7.02.7.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
http-0.12.20.13.3
http_parser-3.1.44.0.0
logging-0.11.41.0.1
meta-1.3.01.4.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
petitparser-3.1.04.2.0
pool-1.5.01.5.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.5` on equatable does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

The constraint `^1.18.0` on puppeteer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions puppeteer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

2
likes
80
pub points
67%
popularity

Publisher

dammak.dev

A Dart package that allows you to test your network download and upload speed using fast.com.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, flutter, puppeteer

More

Packages that depend on fastnet