fast 0.4.0+1

Dart native
Flutter Android iOS

A sample command-line application.

10
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Oct 22, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 49 out of 505 API elements (9.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:fast/fast.dart that imports:
  • package:fast/commands/flutter/snippets_command.dart that imports:
  • package:fast/commands/command_base.dart that imports:
  • package:fast/logger.dart that imports:
  • package:logger/logger.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: The value of the local variable 'result' isn't used.

lib/bash_manager.dart:26:9

   ╷
26 │     var result =
   │         ^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/bash_manager.dart

INFO: This function has a return type of 'FutureOr

lib/core/directory/directory.dart:63:34

   ╷
63 │   Future<List<FileSystemEntity>> getAllSystemFiles() async {
   │                                  ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/core/directory/directory.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.21.6.01.6.0
flunt_dart^0.4.00.4.00.4.0
http^0.12.10.12.20.12.2
json2yaml^1.0.11.0.11.0.1
logger^0.7.0+20.7.0+20.9.4
path^1.6.41.7.01.7.0
plain_optional^0.1.30.1.30.1.3
process_run^0.10.30.10.12+30.11.0+2
pubspec_yaml^2.0.12.0.12.0.1
yaml^2.2.12.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
functional_data-0.3.00.3.0
http_parser-3.1.43.1.4
io-0.3.40.3.4
meta-1.2.31.2.3
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
sum_types-0.2.1+20.2.1+2
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.0+2` on logger does not support the latest published version `0.9.4`

pubspec.yaml:17:11

   ╷
17 │   logger: ^0.7.0+2
   │           ^^^^^^^^
   ╵
The constraint `^0.10.3` on process_run does not support the latest published version `0.11.0+2`

pubspec.yaml:19:16

   ╷
19 │   process_run: ^0.10.3
   │                ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs