fancy_on_boarding 1.7.0 icon indicating copy to clipboard operation
fancy_on_boarding: ^1.7.0 copied to clipboard

A Flutter package for a quick, handy and beautiful OnBoarding screen library.

142
likes
80/ 130
pub points
86%
popularity

We analyzed this package 40 hours ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 27 API elements (3.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:fancy_on_boarding/fancy_on_boarding.dart that imports:
  • package:fancy_on_boarding/src/fancy_on_boarding.dart that imports:
  • package:fancy_on_boarding/src/pager_indicator.dart that imports:
  • package:fancy_on_boarding/src/fancy_image.dart that imports:
  • package:flutter_svg/flutter_svg.dart that imports:
  • package:flutter_svg/svg.dart that imports:
  • package:flutter_svg/src/picture_provider.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.26.0-18.0.pre..

lib/src/fancy_on_boarding.dart:111:17

    ╷
111 │                 FlatButton(
    │                 ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fancy_on_boarding.dart

INFO: 'FlatButton.FlatButton' is deprecated and shouldn't be used. Use TextButton instead. See the migration guide in flutter.dev/go/material-button-migration-guide). This feature was deprecated after v1.26.0-18.0.pre..

lib/src/fancy_on_boarding.dart:111:17

    ╷
111 │                 FlatButton(
    │                 ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/fancy_on_boarding.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
flutter_svg^0.19.10.19.31.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
convert-2.1.13.0.1
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
path_drawing-0.4.1+11.0.0
path_parsing-0.1.41.0.0
petitparser-3.1.05.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
xml-4.5.16.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.19.1` on flutter_svg does not support the stable version `0.21.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.

142
likes
80
pub points
86%
popularity

Publisher

unverified uploader

A Flutter package for a quick, handy and beautiful OnBoarding screen library.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_svg

More

Packages that depend on fancy_on_boarding