fancy_dialog 1.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 90

Fancy Flutter Alert Dialog #

A flutter Package to show custom alert Dialog,you can choose between two themes 'Fancy' and 'Flat'

Usage #

Import the Package #

add this dependencies to your app dependencies: fancy_dialog: ^1.0.1 other versions are documentation improvements

Use the Package #

add this import statement import 'package:fancy_dialog/fancy_dialog.dart';

to show a Basic Dialog

showDialog(
              context: context,
              builder: (BuildContext context) => FancyDialog(
                title: "Fancy Gif Dialog",
                descreption: "This is descreption for fancy gif,you can load any image or gif to be displayed :), and you can choose between two themes Fancy and Flat",
                )
            ) 
         }, 

the title and descreption are required and the rest of the parameters are :

  • okFun : the function to be called when the user press Ok button (positive button)

  • cancelFun : the function to be called when the user press cancel button (negative button)

  • cancelColor : the color of the negative button, by default it's Colors.grey

  • oklColor : the color of the positive button, by default it's Colors.pink

  • ok : the text of the positive button, by default it's 'OK !'

  • cancel : the text of the negative button, by default it's 'cancel'

  • animationType : The type of the animation, there are 4 types,which are :

    • FancyAnimation.LEFT_RIGHT the default one
    • FancyAnimation.RIGHT_LEFT
    • FancyAnimation.TOP_BOTTOM
    • FancyAnimation.BOTTOM_TOP
  • gifpath : the path for the image or the GIF to be displayed,or you can choose between 6 Gifs the package provides :

    • FancyGif.MOVE_FORWARD the default one
    • FancyGif.CHECK_MAIL
    • FancyGif.FUNNY_MAN
    • FancyGif.PLAY_MEDIA
    • FancyGif.SUBMIT
    • FancyGif.SHARE
  • theme : Fancy or Flat

    • FancyTheme.FANCY
    • FancyTheme.FLAT

The dialog will be dissmised by default when the user click Ok or cancel, DON'T ADD Navigator.of(context).pop() to okFun or cancelFun

ScreenShots #

Contribution #

Feel free to contribute, to report a bug to suggest a feature, Thank you :)

[0.0.1] : 21/08/2019.

  • First version.

[1.0.0] : 22/08/2019.

  • Update Demo.
  • Add Screenshots.
  • Update coode.

[1.0.1] : 22/08/2019.

  • Update readme

[1.0.2] : 24/08/2019.

  • Update readme (The markdown issue)

[1.0.3] : 25/08/2019.

  • Fixing screenshots issue

example/README.md

Fancy Flutter Alert Dialog #

A flutter Package to show custom alert Dialog,you can choose between two themes 'Fancy' and 'Flat'

Usage #

Import the Package #

add this dependencies to your app dependencies: fancy_dialog: ^1.0.1

Use the Package #

add this import statement import 'package:fancy_dialog/fancy_dialog.dart';

to show a Basic Dialog

showDialog(
              context: context,
              builder: (BuildContext context) => FancyDialog(
                title: "Fancy Gif Dialog",
                descreption: "This is descreption for fancy gif,you can load any image or gif to be displayed :), and you can choose between two themes Fancy and Flat",
                )
            ) 
         }, 

the title and descreption are required and the rest of the parameters are :

  • okFun : the function to be called when the user press Ok button (positive button)

  • cancelFun : the function to be called when the user press cancel button (negative button)

  • cancelColor : the color of the negative button, by default it's Colors.grey

  • oklColor : the color of the positive button, by default it's Colors.pink

  • ok : the text of the positive button, by default it's 'OK !'

  • cancel : the text of the negative button, by default it's 'cancel'

  • animationType : The type of the animation, there are 4 types,which are :

    • FancyAnimation.LEFT_RIGHT the default one
    • FancyAnimation.RIGHT_LEFT
    • FancyAnimation.TOP_BOTTOM
    • FancyAnimation.BOTTOM_TOP
  • gifpath : the path for the image or the GIF to be displayed,or you can choose between 6 Gifs the package provides :

    • FancyGif.MOVE_FORWARD the default one
    • FancyGif.CHECK_MAIL
    • FancyGif.FUNNY_MAN
    • FancyGif.PLAY_MEDIA
    • FancyGif.SUBMIT
    • FancyGif.SHARE
  • theme : Fancy or Flat

    • FancyTheme.FANCY
    • FancyTheme.FLAT

The dialog will be dissmised by default when the user click Ok or cancel, DON'T ADD Navigator.of(context).pop() to okFun or cancelFun

ScreenShots #

Contribution #

Feel free to contribute, to report a bug to suggest a feature, Thank you :)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  fancy_dialog: ^1.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:fancy_dialog/fancy_dialog.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
81
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
90
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/fancy_dialog.dart. (-1.49 points)

Analysis of lib/fancy_dialog.dart reported 3 hints:

line 164 col 20: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.

line 252 col 26: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.

line 269 col 26: Set literals weren't supported until version 2.2, but this code is required to be able to run on earlier versions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test