fancy_death 0.0.1+3 copy "fancy_death: ^0.0.1+3" to clipboard
fancy_death: ^0.0.1+3 copied to clipboard

outdated

Flutter plugin to replace death error screen and getting possible solutions from github website.

example/lib/main.dart

import 'package:fancy_death/fancy_death.dart';
import 'package:flutter/material.dart';

void main() {
  ErrorWidget.builder =
      (FlutterErrorDetails details) => FancyDeath.fancyDeath(details);
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  //this text is empty so when we use it to get first index will crash
  String someText = '';

  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text(someText[0]),
        ),
      ),
    );
  }
}
1
likes
0
pub points
0%
popularity

Publisher

unverified uploader

Flutter plugin to replace death error screen and getting possible solutions from github website.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

cupertino_icons, flutter, flutter_staggered_animations, http, url_launcher

More

Packages that depend on fancy_death