fake_model 0.0.8 copy "fake_model: ^0.0.8" to clipboard
fake_model: ^0.0.8 copied to clipboard

Automatically generate code for create fake model by annotating Dart classes.

3
likes
130/ 140
pub points
0%
popularity

We analyzed this package 35 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 6 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: fake_model, fake_model.FakeBuilder, fake_model.FakeBuilder.FakeBuilder, fake_model.fakeBuilder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:fake_model/fake_model.dart that imports:
  • package:fake_model/src/generator/generator.dart that imports:
  • package:fake_model/src/helper/fake_model_helper.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:fake_model/fake_model.dart that imports:
  • package:fake_model/src/generator/generator.dart that imports:
  • package:fake_model/src/helper/fake_model_helper.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:fake_model/fake_model.dart that imports:
  • package:fake_model/src/generator/generator.dart that imports:
  • package:fake_model/src/generator/generator_final.dart that imports:
  • package:fake_model/src/util.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/error/error_code_values.g.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/dart/ast/extensions.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/resolver.dart that imports:
  • package:analyzer/src/generated/static_type_analyzer.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inference_helper.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inferrer.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/well_bounded.dart that imports:
  • package:analyzer/src/dart/element/type_algebra.dart that imports:
  • package:analyzer/src/summary2/record_type_builder.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/link.dart that imports:
  • package:analyzer/src/summary2/top_level_inference.dart that imports:
  • package:analyzer/src/task/strong_mode.dart that imports:
  • package:analyzer/src/dart/element/inheritance_manager3.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:analyzer/src/file_system/file_system.dart that imports:
  • package:analyzer/src/util/uri.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.13.0 5.13.0 6.4.1
build ^2.0.0 2.4.1 2.4.1
dart_style ^2.3.1 2.3.2 2.3.6
fake_model_annotation ^0.0.2 0.0.2 0.0.2
meta ^1.3.0 1.12.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 67.0.0
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.13.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

3
likes
130
pub points
0%
popularity

Publisher

verified publisherzyzdev.dev

Automatically generate code for create fake model by annotating Dart classes.

Repository (GitHub)
View/report issues

Topics

#data-model #build-runner #codegen

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, build, dart_style, fake_model_annotation, meta

More

Packages that depend on fake_model