f_orm_m8_sqlite 0.7.1
f_orm_m8_sqlite: ^0.7.1 copied to clipboard

Flutter package to generate SQLite fixture in conjuction with the package f_orm_m8.

0
likes
75/ 130
pub points
15%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 2 links are insecure.

CHANGELOG.md:120:39

    ╷
120 │ <li>The dart package was published as <a href="http://pub.dartlang.org/packages/f_orm_m8_sqlite">f_orm_m8_sqlite</a></li>
    │                                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-23T11:25:10.203762] Starting...
Documenting f_orm_m8_sqlite...
Initialized dartdoc with 724 libraries in 64.9 seconds
Generating docs for library orm_m8_generator from package:f_orm_m8_sqlite/builder.dart...
Generating docs for library entity_writer from package:f_orm_m8_sqlite/generator/entity_writer.dart...
Generating docs for library database_helper_writer from package:f_orm_m8_sqlite/generator/writers/database_helper_writer.dart...
Generating docs for library account_entity_writer from package:f_orm_m8_sqlite/generator/writers/account_entity_writer.dart...
Generating docs for library open_entity_writer from package:f_orm_m8_sqlite/generator/writers/open_entity_writer.dart...
Generating docs for library proxy_writer from package:f_orm_m8_sqlite/generator/writers/proxy_writer.dart...
Generating docs for library entity_writer_factory from package:f_orm_m8_sqlite/generator/writers/entity_writer_factory.dart...
Generating docs for library independent_entity_writer from package:f_orm_m8_sqlite/generator/writers/independent_entity_writer.dart...
Generating docs for library attribute_writer from package:f_orm_m8_sqlite/generator/writers/attribute_writer.dart...
Generating docs for library sql_definition_writer from package:f_orm_m8_sqlite/generator/writers/sql_definition_writer.dart...
Generating docs for library account_related_entity_writer from package:f_orm_m8_sqlite/generator/writers/account_related_entity_writer.dart...
Generating docs for library orm_m8_generator.core from package:f_orm_m8_sqlite/generator/orm_m8_generator_for_annotation.dart...
Generating docs for library validation_collectable from package:f_orm_m8_sqlite/generator/utils/validators/validation_collectable.dart...
Generating docs for library validation_issue from package:f_orm_m8_sqlite/generator/utils/validators/validation_issue.dart...
Generating docs for library orm_m8_generator.core.utils from package:f_orm_m8_sqlite/generator/utils/utils.dart...
Generating docs for library entity_attribute from package:f_orm_m8_sqlite/generator/utils/entity_attribute.dart...
Generating docs for library entity_attribute_from_datetime from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_datetime.dart...
Generating docs for library entity_attribute_from_bigint from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_bigint.dart...
Generating docs for library entity_attribute_from_int from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_int.dart...
Generating docs for library entity_attribute_from_double from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_double.dart...
Generating docs for library entity_attribute_from_bool from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_bool.dart...
Generating docs for library entity_attribute_from_not_implemented from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_not_implemented.dart...
Generating docs for library entity_attribute_from_num from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_num.dart...
Generating docs for library entity_attribute_from_string from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_string.dart...
Generating docs for library entity_attribute_from_duration from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_from_duration.dart...
Generating docs for library orm_m8_generator.core.utils.entity_attribute_types from package:f_orm_m8_sqlite/generator/utils/entity_attribute_types/entity_attribute_types.dart...
Generating docs for library format_utils from package:f_orm_m8_sqlite/generator/utils/format_utils.dart...
Generating docs for library entity_attribute_factory from package:f_orm_m8_sqlite/generator/utils/entity_attribute_factory.dart...
Generating docs for library db_entity_type_enum from package:f_orm_m8_sqlite/generator/utils/db_entity_type_enum.dart...
Generating docs for library table_assertions from package:f_orm_m8_sqlite/generator/utils/type/table_assertions.dart...
Generating docs for library checkers from package:f_orm_m8_sqlite/generator/utils/type/checkers.dart...
Generating docs for library column_assertions from package:f_orm_m8_sqlite/generator/utils/type/column_assertions.dart...
Generating docs for library attribute_metadata_parser from package:f_orm_m8_sqlite/generator/utils/attribute_metadata_parser.dart...
Generating docs for library type_utils from package:f_orm_m8_sqlite/generator/utils/type_utils.dart...
Generating docs for library orm_m8_generator.wrapper from package:f_orm_m8_sqlite/generator/database_helper_generator.dart...
Generating docs for library model_parser from package:f_orm_m8_sqlite/generator/model_parser.dart...
Generating docs for library validation_writer from package:f_orm_m8_sqlite/generator/validation_writer.dart...
Generating docs for library emitted_entity from package:f_orm_m8_sqlite/generator/emitted_entity.dart...
Generating docs for library orm_m8_generator.core from package:f_orm_m8_sqlite/generator/core.dart...
Generating docs for library field_parse_exception from package:f_orm_m8_sqlite/exceptions/field_parse_exception.dart...
Generating docs for library orm_m8_generator.exceptions from package:f_orm_m8_sqlite/exceptions/exception_expander.dart...
Generating docs for library orm_m8_generator from package:f_orm_m8_sqlite/orm_m8_generator.dart...
Generating docs for library m8_builder from package:f_orm_m8_sqlite/m8_builder.dart...
Documented 43 public libraries in 1.5 seconds

stderr:   warning: orm_m8_generator has no library level documentation comments
    from orm_m8_generator: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/builder.dart:1:9)
  warning: orm_m8_generator.core has no library level documentation comments
    from orm_m8_generator.core: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/generator/orm_m8_generator_for_annotation.dart:1:9)
  warning: orm_m8_generator.core.utils has no library level documentation comments
    from orm_m8_generator.core.utils: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/generator/utils/utils.dart:1:9)
  warning: orm_m8_generator.core.utils.entity_attribute_types has no library level documentation comments
    from orm_m8_generator.core.utils.entity_attribute_types: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/generator/utils/entity_attribute_types/entity_attribute_types.dart:1:9)
  warning: orm_m8_generator.wrapper has no library level documentation comments
    from orm_m8_generator.wrapper: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/generator/database_helper_generator.dart:1:9)
  warning: orm_m8_generator.core has no library level documentation comments
    from orm_m8_generator.core: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/generator/core.dart:1:9)
  error: failed to write file at: orm_m8_generator.core/orm_m8_generator.core-library.html
    for symbol orm_m8_generator.core: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/generator/core.dart:1:9)
    conflicting with file already generated by orm_m8_generator.core: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/generator/orm_m8_generator_for_annotation.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            orm_m8_generator.core conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: orm_m8_generator.exceptions has no library level documentation comments
    from orm_m8_generator.exceptions: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/exceptions/exception_expander.dart:1:9)
  warning: orm_m8_generator has no library level documentation comments
    from orm_m8_generator: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/orm_m8_generator.dart:1:9)
  error: failed to write file at: orm_m8_generator/orm_m8_generator-library.html
    for symbol orm_m8_generator: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/orm_m8_generator.dart:1:9)
    conflicting with file already generated by orm_m8_generator: (file:///tmp/pub-dartlang-dartdocAFBBGW/pkg/lib/builder.dart:1:9)
Found 8 warnings and 2 errors.
Unhandled exception:
encountered 2 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:241:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:f_orm_m8_sqlite/builder.dart that imports:
  • package:f_orm_m8_sqlite/m8_builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.00.39.172.7.0
build>=0.12.0 <2.0.01.6.22.1.1
f_orm_m8^0.8.00.8.0+30.8.0+3
path^1.6.21.8.01.8.0
source_gen^0.9.50.9.10+21.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.030.0.0
args-1.6.02.3.0
async-2.8.22.8.2
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
dart_style-1.3.62.2.0
file-5.2.16.1.2
glob-1.2.02.0.2
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.21.0.2
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.39.0` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `>=0.12.0 <2.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
75
pub points
15%
popularity

Flutter package to generate SQLite fixture in conjuction with the package f_orm_m8.

Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, build, f_orm_m8, path, source_gen

More

Packages that depend on f_orm_m8_sqlite