ezkit 0.0.1
ezkit: ^0.0.1 copied to clipboard

Flutter Android iOS macOS web
unlisted

A collection of usefull things, including routing, util and widgets for Flutter applications

1
likes
80 / 100
pub points
0 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 80 pub points (of a possible 100):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • Homepage URL isn't helpful.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/main.dart
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:ezkit/ezkit.dart that imports:
  • package:ezkit/widgets.dart that imports:
  • package:ezkit/widgets/paper.dart that imports:
  • package:ezkit/utils.dart that imports:
  • package:ezkit/utils/storage.dart that imports:
  • package:localstorage/localstorage.dart that imports:
  • package:localstorage/src/directory/directory.dart that imports:
  • package:localstorage/src/directory/io.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_linux/path_provider_linux.dart that declares support for platforms: Linux
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.90.4.9+53.0.2
flutterflutter0.0.00.0.0
flutter_secure_storage^3.3.33.3.54.0.0
http^0.12.20.12.20.13.0
intl^0.16.10.16.10.17.0
localstorage^3.0.23.0.6+93.0.6+9
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
path-1.8.01.8.0
path_provider-1.6.272.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.1.04.1.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.02.0.0
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.4.9` on connectivity does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

The constraint `^3.3.3` on flutter_secure_storage does not support the stable version `4.0.0`, that was published 10 days ago.

When flutter_secure_storage is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_secure_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Flutter 1.26.0-17.8.pre, Dart 2.12.0 (build 2.12.0-259.16.beta).

1
likes
80
pub points
0%
popularity

Publisher

ez-connect.net

A collection of usefull things, including routing, util and widgets for Flutter applications

Homepage

License

MIT (LICENSE)

Dependencies

connectivity, flutter, flutter_secure_storage, http, intl, localstorage

More

Packages that depend on ezkit