explode_view 1.0.4
explode_view: ^1.0.4 copied to clipboard

A beautiful animation library for Flutter which explodes the image into small particles. This package can be used whenever there is a need of removing the image from the screen.

32
likes
90 / 130
pub points
56 %
popularity

We analyzed this package on Jul 31, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 85 API elements (18.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
image^2.1.42.1.193.0.2
vector_math^2.0.82.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.2.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
meta-1.3.01.7.0
path-1.8.01.8.0
petitparser-3.1.04.2.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
xml-4.5.15.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.4` on image does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.3 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

32
likes
90
pub points
56%
popularity

Publisher

ayushagarwal.ml

A beautiful animation library for Flutter which explodes the image into small particles. This package can be used whenever there is a need of removing the image from the screen.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, image, vector_math

More

Packages that depend on explode_view