expandable_group 0.0.8 copy "expandable_group: ^0.0.8" to clipboard
expandable_group: ^0.0.8 copied to clipboard

A new Flutter widget support expanded and collapsed list for user..

7
likes
90/ 140
pub points
82%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 12 API elements (75.0 %) have documentation comments.

Some symbols that are missing documentation: expandable_group, expandable_group_widget.ExpandableGroup, expandable_group_widget.ExpandableGroup.ExpandableGroup.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The getter 'color' isn't defined for the type 'AppBarTheme'.

lib/expandable_group_widget.dart:93:76

   ╷
93 │       color: widget.headerBackgroundColor ?? Theme.of(context).appBarTheme.color,
   │                                                                            ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/expandable_group_widget.dart

INFO: Dangling library doc comment.

lib/expandable_group_widget.dart:1:1

  ╷
1 │ ///
  │ ^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/expandable_group_widget.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

7
likes
90
pub points
82%
popularity

Publisher

verified publisherliemvo.xyz

A new Flutter widget support expanded and collapsed list for user..

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on expandable_group