expand_widget 0.2.0+2

Expand Widget #

Package License Stars PayPal Patreon

This Dart package offers developers a streamlined library of Flutter widgets, useful for expanding general & text widgets, when user wishes.

When the users clicks the 'expand' arrow, the hidden widgets or content unfold with a cool animation.

There are two main 'expand' widgets:

  • Expand Child: Useful to show more widgets related to the content already visible by the user.
  • Expand Text: Useful when texts can be quite big for a small screen. It adds the ability to show the full content if the user wants to.
  • Show Child: In contrast to the 'Expand Child' widget, it doesn't have the ability to hide again the content.

Example #

Here is an example of a simple use of this package, from the ExpandChild, ExpandText & ShowChild widgets. If you want to take a deeper look at the example, take a look at the example/ folder provided with the project.

ExpandChild(
  child: Column(
    children: <Widget>[
      OutlineButton(
        child: Text('Button1'),
        onPressed: () => print('Pressed button1'),
      ),
      OutlineButton(
        child: Text('Button2'),
        onPressed: () => print('Pressed button2'),
      ),
      OutlineButton(
        child: Text('Button3'),
        onPressed: () => print('Pressed button3'),
      ),
    ],
  ),
),
ExpandText(
  'Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.',
  textAlign: TextAlign.justify,
),
ShowChild(
indicator: Padding(
  padding: EdgeInsets.all(8),
  child: Text(
    "SHOW MORE",
    style: TextStyle(
      color: Theme.of(context).textTheme.caption.color,
    ),
  ),
),
child: Column(
  children: <Widget>[
    OutlineButton(
      child: Text('Button1'),
      onPressed: () => print('Pressed button1'),
    ),
    OutlineButton(
      child: Text('Button2'),
      onPressed: () => print('Pressed button2'),
    ),
    OutlineButton(
      child: Text('Button3'),
      onPressed: () => print('Pressed button3'),
    ),
  ],
),

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Built with #

Authors #

License #

This project is licensed under the GNU GPL v3 License - see the LICENSE.md file for details.

[0.2.0+2] - June 24th, 2019

  • Added ShowChild widget.

[0.1.2] - June 8th, 2019

  • Default arrow size changed to 27.
  • Updated example project.

[0.1.1] - June 7th, 2019

  • Increased maxLenght from 5 to 8.

[0.1.0] - June 7th, 2019

  • First release of this package!

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  expand_widget: ^0.2.0+2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:expand_widget/expand_widget.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
85
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Aug 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test