executor_lib 1.1.1 copy "executor_lib: ^1.1.1" to clipboard
executor_lib: ^1.1.1 copied to clipboard

Provides an abstraction for executing jobs.

1
likes
120/ 140
pub points
74%
popularity

We analyzed this package 7 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

35 out of 54 API elements (64.8 %) have documentation comments.

Some symbols that are missing documentation: executors.CancellationCallback, executors.ConcurrencyExecutor.disposed, executors.ConcurrencyExecutor.queueSize, executors.ConcurrencyExecutor.submit, executors.DirectExecutor.disposed.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:executor_lib/executor_lib.dart that imports:
  • package:executor_lib/src/queue_executor.dart that imports:
  • package:executor_lib/src/executor.dart that imports:
  • package:executor_lib/src/pool_executor.dart that imports:
  • package:executor_lib/src/isolate_executor.dart that imports:
  • dart:isolate
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.8.2 2.11.0 2.11.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

1
likes
120
pub points
74%
popularity

Publisher

verified publishergreensopinion.com

Provides an abstraction for executing jobs.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

async, flutter

More

Packages that depend on executor_lib