excel_it 1.0.5

Dart native js
Flutter Android iOS web

A flutter and dart library for creating, editing and updating excel sheets with compatible both on client and server side.

9
likes
80 / 110
pub points
24 %
popularity

We analyzed this package on Sep 23, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/kawal7415/excel_it was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/excel_it.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 27 out of 51 API elements (52.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

INFO: Don't explicitly initialize variables to null.

lib/src/excel.dart:31:7

   ╷
31 │   var format = null;
   │       ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/excel.dart

INFO: Use contains instead of indexOf

lib/src/excel.dart:246:18

    ╷
246 │               '${_patternFill.indexOf(color[1]) == -1 ? 0 : _patternFill.indexOf(color[1]) + 2}',
    │                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/excel.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.02.0.132.0.13
xml^3.0.03.7.04.5.1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
meta-1.2.31.2.3
petitparser-3.1.03.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0` on xml does not support the latest published version `4.5.1`

pubspec.yaml:11:8

   ╷
11 │   xml: ^3.0.0
   │        ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
80
pub points
24%
popularity

A flutter and dart library for creating, editing and updating excel sheets with compatible both on client and server side.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

kawal741536@gmail.com

License

MIT (LICENSE)

Dependencies

archive, xml

More

Packages that depend on excel_it