example 0.0.1

Flutter Android iOS

flutter_i18n example app, ready to use

0
likes
55 / 110
pub points
40 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 8 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:example/main.dart that imports:
  • package:flutter_i18n/flutter_i18n_delegate.dart that imports:
  • package:flutter_i18n/flutter_i18n.dart that imports:
  • package:intl/intl_standalone.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/main.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^0.1.20.1.31.0.0
flutterflutter0.0.00.0.0
flutter_i18n^0.0.20.0.30.19.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
flutter_localizations-0.0.00.0.0
intl-0.16.10.16.1
meta-1.1.81.2.3
path-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.2` on cupertino_icons does not support the latest published version `1.0.0`

pubspec.yaml:11:20

   ╷
11 │   cupertino_icons: ^0.1.2
   │                    ^^^^^^
   ╵
The constraint `^0.0.2` on flutter_i18n does not support the latest published version `0.19.2`

pubspec.yaml:10:17

   ╷
10 │   flutter_i18n: ^0.0.2
   │                 ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs