eventstateprocessor 0.1.0 copy "eventstateprocessor: ^0.1.0" to clipboard
eventstateprocessor: ^0.1.0 copied to clipboard

outdated

A Flutter package that wrap flutter bloc package for clearer implementation

4
likes
80/ 140
pub points
58%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

153 out of 154 API elements (99.4 %) have documentation comments.

Some symbols that are missing documentation: eventstateprocessor.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

ERROR: The argument type 'bool?' can't be assigned to the parameter type 'bool'.

lib/src/vn/com/extremevn/event_state_processor/processor.dart:75:17

   ╷
75 │           lazy: lazy,
   │                 ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/vn/com/extremevn/event_state_processor/processor.dart

INFO: Dangling library doc comment.

lib/src/vn/com/extremevn/event_state_processor/processor.dart:1:1

  ╷
1 │ /// MIT License
  │ ^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/vn/com/extremevn/event_state_processor/processor.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_bloc ^7.0.1 7.3.3 8.1.5
pedantic ^1.9.2 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
bloc - 7.2.1 8.1.4
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.0.1` on flutter_bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

4
likes
80
pub points
58%
popularity

Publisher

verified publisherextremevn.com.vn

A Flutter package that wrap flutter bloc package for clearer implementation

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_bloc, pedantic

More

Packages that depend on eventstateprocessor