eventpub 0.0.2 copy "eventpub: ^0.0.2" to clipboard
eventpub: ^0.0.2 copied to clipboard

A event manager library

1
likes
100/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 40 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: eventpub, eventpub.EventPub, eventpub.EventPub.EventPub, eventpub.EventPub.dispatch, eventpub.EventPub.dispose.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:eventpub/eventpub.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:eventpub/eventpub.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:eventpub/eventpub.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:eventpub/eventpub.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The type name 'eventpubInterface' isn't an UpperCamelCase identifier.

lib/eventpub_interface.dart:3:7

  ╷
3 │ class eventpubInterface {
  │       ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/eventpub_interface.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.