event_bus_auto 0.1.0 copy "event_bus_auto: ^0.1.0" to clipboard
event_bus_auto: ^0.1.0 copied to clipboard

A tool for generating un/registerEvents method for EventBus, based on build_runner.

1
likes
120/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://blog.tshine.me was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting event_bus_auto... Discovering libraries... Linking elements... Precaching local docs for 136858 elements... Initialized dartdoc with 49 libraries Generating docs for library event.dart from package:event_bus_auto/event.dart... Generating docs for library event_bus_auto.dart from package:event_bus_auto/event_bus_auto.dart... Generating docs for library event_error.dart from package:event_bus_auto/event_error.dart... Generating docs for library event_auto.dart from package:event_bus_auto/event_auto.dart... Documented 4 public libraries in 47.1 seconds ERR: warning: event_bus_auto has no library level documentation comments from event_bus_auto: (file:///tmp/pana_DIRYDY/lib/event.dart:1:9) warning: event_bus_auto has no library level documentation comments from event_bus_auto: (file:///tmp/pana_DIRYDY/lib/event_bus_auto.dart:1:9) error: failed to write file at: event_bus_auto/event_bus_auto-library.html for symbol event_bus_auto: (file:///tmp/pana_DIRYDY/lib/event_bus_auto.dart:1:9) conflicting with file already generated by event_bus_auto: (file:///tmp/pana_DIRYDY/lib/event.dart:1:9) Dartdoc generates a path and filename to write to for each symbol. 'event_bus_auto' conflicts with another symbol in the generated path, and therefore can not be written out. Changing the name, library name, [13 more lines]

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
event_bus ^2.0.0 2.0.0 2.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

1
likes
120
pub points
0%
popularity

Publisher

unverified uploader

A tool for generating un/registerEvents method for EventBus, based on build_runner.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

event_bus

More

Packages that depend on event_bus_auto