essential_kit 0.0.4 copy "essential_kit: ^0.0.4" to clipboard
essential_kit: ^0.0.4 copied to clipboard

It contains a collection of essential functions and widgets that are necessary for building any application.

2
likes
130/ 160
pub points
27%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 47 API elements (6.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: essential_kit, essential_kit.NotificationService, essential_kit.NotificationService.NotificationService, essential_kit.NotificationService.initNotification, essential_kit.NotificationService.notificationDetails.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:essential_kit/essential_kit.dart that imports:
  • package:essential_kit/src/functions.dart that imports:
  • package:essential_kit/src/functions/notifications.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that declares support for platforms: Android, iOS, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:essential_kit/essential_kit.dart that imports:
  • package:essential_kit/src/functions.dart that imports:
  • package:essential_kit/src/functions/notifications.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that declares support for platforms: Android, iOS, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:essential_kit/essential_kit.dart that imports:
  • package:essential_kit/src/functions.dart that imports:
  • package:essential_kit/src/functions/notifications.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:essential_kit/essential_kit.dart that imports:
  • package:essential_kit/src/functions.dart that imports:
  • package:essential_kit/src/functions/notifications.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:essential_kit/essential_kit.dart that imports:
  • package:essential_kit/src/functions.dart that imports:
  • package:essential_kit/src/functions/notifications.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications/src/notification_details.dart that imports:
  • package:flutter_local_notifications_linux/flutter_local_notifications_linux.dart that imports:
  • package:flutter_local_notifications_linux/src/flutter_local_notifications.dart that imports:
  • package:flutter_local_notifications_linux/src/notifications_manager.dart that imports:
  • package:flutter_local_notifications_linux/src/storage.dart that imports:
  • package:flutter_local_notifications_linux/src/platform_info.dart that imports:
  • package:xdg_directories/xdg_directories.dart that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_local_notifications ^13.0.0 13.0.0 17.1.2
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
flutter_local_notifications_linux - 3.0.0+1 4.0.0+1
flutter_local_notifications_platform_interface - 6.0.0 7.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
process - 4.2.4 5.0.2
sky_engine - 0.0.99 0.0.99
timezone - 0.9.3 0.9.3
vector_math - 2.1.4 2.1.4
xdg_directories - 0.2.0+3 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^13.0.0` on flutter_local_notifications does not support the stable version `14.0.0`.

Try running dart pub upgrade --major-versions flutter_local_notifications to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
130
pub points
27%
popularity

Publisher

unverified uploader

It contains a collection of essential functions and widgets that are necessary for building any application.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_local_notifications

More

Packages that depend on essential_kit