esp_provisioning 1.0.0+6
esp_provisioning: ^1.0.0+6 copied to clipboard

Espressif Provisioning library

11
likes
60/ 130
pub points
64%
popularity

We analyzed this package 4 days ago, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 93 API elements (1.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:esp_provisioning/esp_provisioning.dart that declares support for platforms: Android, iOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 30 issues. Showing the first 2:

lib/esp_provisioning.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/crypt.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.131.15.01.15.0
cryptography^1.4.11.4.12.0.5
flutterflutter0.0.00.0.0
flutter_ble_lib^2.3.22.3.22.3.2
protobuf^1.0.11.1.42.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
js-0.6.30.6.3
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.4.1` on cryptography does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cryptography to update the constraint.

The constraint `^1.0.1` on protobuf does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.