epubx 4.0.0 copy "epubx: ^4.0.0" to clipboard
epubx: ^4.0.0 copied to clipboard

Epub Parser for Dart. Epub package fork. Suitable for use on the Server, the Web, or in Flutter

54
likes
120/ 140
pub points
87%
popularity

We analyzed this package 3 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

74 out of 250 API elements (29.6 %) have documentation comments.

Some symbols that are missing documentation: epubx, epubx.EnumFromString, epubx.EnumFromString.EnumFromString, epubx.EnumFromString.enumValues, epubx.EnumFromString.get.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 153 issues. Showing the first 2:

INFO: The variable name 'Title' isn't a lowerCamelCase identifier.

lib/src/entities/epub_book.dart:10:11

   ╷
10 │   String? Title;
   │           ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/entities/epub_book.dart

INFO: The variable name 'Author' isn't a lowerCamelCase identifier.

lib/src/entities/epub_book.dart:11:11

   ╷
11 │   String? Author;
   │           ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/entities/epub_book.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.1.6 3.4.10 3.4.10
collection ^1.15.0 1.18.0 1.18.0
image ^3.0.8 3.3.0 4.1.7
path ^1.8.1 1.9.0 1.9.0
quiver ^3.0.1+1 3.2.1 3.2.1
xml ^6.0.1 6.5.0 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
js - 0.7.1 0.7.1
matcher - 0.12.16+1 0.12.16+1
meta - 1.14.0 1.14.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.9.0 3.9.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.8` on image does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

54
likes
120
pub points
87%
popularity

Publisher

verified publisherserge.software

Epub Parser for Dart. Epub package fork. Suitable for use on the Server, the Web, or in Flutter

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

archive, collection, image, path, quiver, xml

More

Packages that depend on epubx