embedded_config 0.1.3
embedded_config: ^0.1.3 copied to clipboard

Allows application configs to be embedded directly into source code at build-time. Configuration can come from JSON files, environment variables, and build.yaml files.

0
likes
80 / 110
pub points
19 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:embedded_config/embedded_config.dart that imports:
  • package:embedded_config/src/config_generator.dart that imports:
  • package:embedded_config/src/key_config.dart that imports:
  • package:embedded_config/src/build_exception.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/embedded_config.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/build_exception.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.32.4 <0.40.00.39.171.4.0
build^1.0.01.6.22.0.0
code_builder^3.2.03.7.03.7.0
embedded_config_annotations>=0.1.0 <0.2.00.1.10.1.1
source_gen^0.9.00.9.10+21.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.020.0.0
args-1.6.02.0.0
async-2.5.02.5.0
built_collection-5.0.05.0.0
built_value-8.0.48.0.4
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
dart_style-1.3.62.0.0
file-5.2.16.1.0
fixnum-1.0.01.0.0
glob-1.2.02.0.1
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.11.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
node_interop-1.2.12.0.0
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pub_semver-1.4.42.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=0.32.4 <0.40.0` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.0.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
80
pub points
19%
popularity

Allows application configs to be embedded directly into source code at build-time. Configuration can come from JSON files, environment variables, and build.yaml files.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

ethan.lafrenais@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, code_builder, embedded_config_annotations, source_gen

More

Packages that depend on embedded_config