ele_theme 0.0.1 copy "ele_theme: ^0.0.1" to clipboard
ele_theme: ^0.0.1 copied to clipboard

flutter element theme.

90/ 140
pub points

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: ele_theme,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: ele_theme.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting ele_theme... Discovering libraries... Linking elements... Precaching local docs for 592130 elements... Initialized dartdoc with 724 libraries Generating docs for library ele_theme.dart from package:ele_theme/ele_theme.dart... Generating docs for library ele_border_theme_data.dart from package:ele_theme/ele_border_theme_data.dart... Generating docs for library ele_button_theme_data.dart from package:ele_theme/ele_button_theme_data.dart... Generating docs for library ele_theme_data.dart from package:ele_theme/ele_theme_data.dart... Generating docs for library extensions.dart from package:ele_theme/extensions.dart... [1 more lines] ERR: warning: ele_theme has no library level documentation comments from ele_theme: (file:///tmp/pana_TGSYUH/lib/ele_theme.dart:1:9) warning: ele_theme has no library level documentation comments from ele_theme: (file:///tmp/pana_TGSYUH/lib/ele_border_theme_data.dart:1:9) error: failed to write file at: ele_theme/ele_theme-library.html for symbol ele_theme: (file:///tmp/pana_TGSYUH/lib/ele_border_theme_data.dart:1:9) conflicting with file already generated by ele_theme: (file:///tmp/pana_TGSYUH/lib/ele_theme.dart:1:9) Dartdoc generates a path and filename to write to for each symbol. 'ele_theme' conflicts with another symbol in the generated path, and therefore can not be written out. Changing the name, library name, or [37 more lines]

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The operand can't be null, so the condition is always 'true'.


43 │   })  : assert(theme != null),
   │                      ^^^^^^^

To reproduce make sure you are using the lints_core and run flutter analyze lib/ele_theme.dart

INFO: The import of 'package:flutter/foundation.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/cupertino.dart'.


4 │ import 'package:flutter/foundation.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

To reproduce make sure you are using the lints_core and run flutter analyze lib/ele_theme.dart

Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

pub points


unverified uploader

flutter element theme.

Repository (GitHub)
View/report issues


API reference


Apache-2.0 (LICENSE)




Packages that depend on ele_theme